www.ice-graphics.com Forum Index www.ice-graphics.com
The main forum for the ICE-Graphics software
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

V2.2 Path Error Bug

 
Post new topic   Reply to topic    www.ice-graphics.com Forum Index -> Bugs and Problems
View previous topic :: View next topic  
Author Message
misato



Joined: 16 May 2005
Posts: 3

PostPosted: Thu Dec 08, 2005 10:36 am    Post subject: V2.2 Path Error Bug Reply with quote

I've found a bug using version 2.2

I have a directory R:\TEMP01\ whith a bunch of files and subdirs. I highlight that dir in ICEECC and make ECC recovery files, and they appear in R:\TEMP01\, as I expect. I use create-and-test, and the test completes fine.

Then I double click on the .ECC files to see how it verifies, and it fails, unrecoverable (not enough recovery files).

The problem is it can't find the original data files at R:\TEMP01\TEMP01\ so it thinks they are all lost.

If I create an R:\TEMP01\TEMP01\ and move the data files there, it verifies okay. But the ECC files must be in R:\TEMP01\ for the test to succeed.

2.1 did the same thing.

Remember, the verify immediately after create works correctly, but a later verify uses a different path.

I'm a bit surprised this hasn't been reported before.

Thanks!
Back to top
View user's profile Send private message
ICE Graphics
Site Admin


Joined: 31 Mar 2003
Posts: 430

PostPosted: Sun Dec 25, 2005 1:58 pm    Post subject: Re: V2.2 Path Error Bug Reply with quote

misato wrote:
I've found a bug using version 2.2

I have a directory R:\TEMP01\ whith a bunch of files and subdirs. I highlight that dir in ICEECC and make ECC recovery files, and they appear in R:\TEMP01\, as I expect. I use create-and-test, and the test completes fine.

Then I double click on the .ECC files to see how it verifies, and it fails, unrecoverable (not enough recovery files).

The problem is it can't find the original data files at R:\TEMP01\TEMP01\ so it thinks they are all lost.

If I create an R:\TEMP01\TEMP01\ and move the data files there, it verifies okay. But the ECC files must be in R:\TEMP01\ for the test to succeed.

2.1 did the same thing.

Remember, the verify immediately after create works correctly, but a later verify uses a different path.

I'm a bit surprised this hasn't been reported before.

It's not bug. ICE ECC store relative path to all data files. For example: you have directory E:\ABC with file test.jpg for example.

If you create ECC file from Data directory E:\ABC, full pathname for your file in ECC file is "test.jpg". But if you create ECC file from Root (E:\), marking directory ABC, full pathname for your file in ECC file is "ABC\test.jpg". It's correct.

If you made ECC file using path E:\ by defult, instead of E:\ABC, you have to use E:\ and for verify.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    www.ice-graphics.com Forum Index -> Bugs and Problems All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group